
MAHATMA GANDHI UNIVERSITY, KOTTAYAM 

MGU-UGP (HONOURS) 

FIRST SEMESTER EXAMINATION (2024 ADMISION ONWARDS) 

MG1DSCCMA100– Documentation Tools and Techniques 

Duration: 1.5 hrs Maximum Marks: 50 

Students should attempt atleast one question from each course outcome to enhance their 

overall outcome attainability. 

Part A - Multiple Choice Questions 

Answer All Questions. Each question carries 1 mark 
 

1. Which of the following is a feature of LibreOffice Writer? [U] [1] 

a) Graphical User Interface 

b) Mail Merge 

c) HTML Formatting 

d) Image Editing 

2. In LibreOffice Writer, which tool is used to adjust page layout? [U] [1] 

a) Format Painter 

b) Page Setup 

c) Table Layout 

d) Graphic Styles 

3. How can you add images in LibreOffice Writer? [U]   [1] 

a) Insert > Media > Image 

b) Format > Picture > Add 

c) File > Open > Image 

d) Tools > Insert Image 

4. What is the default file format for saving documents in LibreOffice Writer? 

a) .docx 

b) .odt 

c) .pdf 

d) .txt 

[U] [1] 

5. LibreOffice Writer can export documents directly to which format? 

a) HTML 

b) PDF 

c) JPG 

d) MP3 
6. Which feature in LibreOffice Writer is used for combining data sources with 

[U] 

 

 

 
 

[U] 

[1] 

 

 

 
 

[1] 

documents? 

a) Export 

b) Mail Merge 

c) Font Management 

d) Typography 

  

7. In LibreOffice Writer, which tool is used to insert a table? 

a) Tools > Add Table 

b) Insert > Table 
c) View > Table 

[U] [1] 



 d) Format > Table   

8. What is the main use of Scribus? 

a) Web Development 

b) Desktop Publishing 

c) Data Analysis 
d) Network Security 

[U] [2] 

9. What is the purpose of 'Master Pages' in Scribus? 

a) Content Editing 

b) Image Formatting 

c) Consistent Page Layout 

d) Data Entry 

[U] [2] 

10. What is 'Story Editor' in Scribus used for? 

a) Editing stories online 

b) Managing styles 

c) Advanced text editing 

d) Graphic design 

[U] [2] 

11. What type of documents can be created using Scribus? 

a) Spreadsheets 

b) Databases 

c) Brochures and Magazines 

d) Presentations 

[U] [2] 

12. In Scribus, what does 'Typography' include? 

a) Image Formatting 

b) Text Editing 

c) Font Management 

d) Mail Merge 

[U] [2] 

13. What type of software is Scribus primarily known as? 

a) Video Editing Software 

b) Desktop Publishing Software 

c) Animation Software 
d) Web Hosting Software 

[U] [2] 

14. Which feature in Google Docs allows for voice input? 

a) Text Formatting 

b) Dictate Text 

c) Mail Merge 

d) Page Layout 

[U] [3] 

15. Which shortcut key is used to create a new document in Google Docs? 

a) Ctrl + N 

b) Ctrl + D 

c) Ctrl + S 

d) Ctrl + G 

[U] [3] 

16. Which of the following features is NOT available in Google Docs? 

a) Real-time collaboration 
b) Mail Merge 

[U] [3] 



 c) Voice Dictation 

d) Add-ons 
  

17. Which of the following is a collaboration tool in Google Docs? 

a) Revision History 

b) Text Highlight 

c) Page Layout 

d) Export as PDF 

[U] [3] 

18. How can text be formatted in Google Docs? 

a) Using the toolbar options 

b) Through the Control Panel 

c) With the Options Menu 

d) Via Command Prompt 

[U] [3] 

19. What is the purpose of 'Wrap Text' around images in Google Docs? 

a) For better image quality 

b) To control text flow around images 

c) For changing image color 

d) To remove images 

[U] [3] 

20. Which tool allows for sharing a Google Docs document with editing 

permissions? 

a) Sharing Link 

b) Comment Box 

c) Print Preview 

d) Image Toolbar 

[U] [3] 

[1 x 20 = 20 marks] 

 Part B - Short Answer Questions 

Answer 10 Questions. Each question carries 3 marks 
  

21. Explain how to apply text styles in LibreOffice Writer and the benefits of using 

styles for document consistency. 

[U] [1] 

22. Discuss how to insert and format a table in LibreOffice Writer. Why might 

tables be beneficial for organizing content? 

[U] [1] 

23. Explain the process of  using Mail Merge in LibreOffice Writer to create 

personalized documents. 

[U] [1] 

24. Discuss how to export a document to PDF format in LibreOffice Writer and why 

PDF might be preferred over other formats. 

[U] [1] 

25. Describe the steps to create a multi-column layout in Scribus and mention one 

situation where this layout is particularly useful. 

[U] [2] 

26. Describe how to import and manipulate an image in Scribus. Include an 

example of when this might be useful in a project. 

[U] [2] 

27. What does the "Page Up" and "Page Down" key do in Scribus? [U] [2] 



28. What is the purpose of Master Pages in Scribus, and how do they enhance document 

design?                                                                                              [U]     [2] 
 

29. List and explain three key features of Google Docs that support collaborative editing. 

                      [U]      [3] 

30. Outline the steps for creating and sharing a document in Google Docs with comments 

and suggestions enabled.              [U]      [3] 

31. Describe how to add page numbers in a Google Docs document and the significance 

of this feature for large documents.                            [U]      [3] 
 

32. Identify three formatting options available in Google Docs for text and paragraph styles. 

Explain when each might be used.                                        [U]      [3] 
 

                                                             [3 x 10 = 30 marks] 



MAHATMA GANDHI UNIVERSITY, KOTTAYAM 
 

MGU-UGP (HONOURS) FIRST SEMESTER EXAMINATION 

(2024 ADMISION ONWARDS) 

MG1DSCCMA101– Introduction to Web Designing 

 

Duration: 1.5 Hrs                                                                                                          Maximum Marks: 50 
 

Students should attempt atleast one question from each course outcome to enhance their overall 

outcome attainability. 

 
Part A 

Very Short Answer Questions 

Answer All Questions 

Each question carries 1 mark 

1. Define World Wide Web (WWW)?       [K][CO1] 

2. Name the following:        [U][CO1] 

a. A tag that is used to group text into paragraphs. 

b. A tag that is used for displaying headings in a webpage. 

3. Which symbol is often used to conclude a declaration in CSS?    [K][CO3] 

4. Give the purpose of HTML5 <aside> element?      [U][CO2] 

5. Mention two popular web servers currently in use.     [K][CO1] 

6. If you want to apply styles only to a specific HTML document, which style would you  

choose?          [U][CO3] 

7. List the tags required in the general structure of an HTML document.  [U][CO1] 

8. Identify the use of <navi> tag?       [U][CO2] 

9. What is the primary difference between a single-select box and a multi-select box in terms 

of user interaction?        [K][CO2] 

10. Define the property that is used to shorten the code in CSS.   [K][CO3] 

                    [1 x 10 = 10] 

     Part B 

Short Answer Questions 

Answer 4 Questions 
Each question carries 5 marks 

 

11. How do the functions of a web server and a web browser differ when it comes to accessing 

web documents?                                 [U][CO1] 
 

12. Explain the four main components in CSS box model that define an elements layout. 

                              [U][CO3] 
 

13. What are hidden form controls, and how do they differ from visible form elements?    

Mention the steps for creating a hidden input field in HTML?             [U][CO2] 
 

 

 



14.   Write the HTML code to create the following list :          [U][CO1] 

  1. RAM  

  2. Registers 

  3. Mother Board 

  4. Cache memory 

  5.ROM 

 

 

15. List five HTML tags used for text formatting and briefly describe their functions. 

                 [U][CO1] 

16. How do radio buttons function in a form to ensure that only one option can be selected 

from a group? What is the significance of the name attribute in this context? 

                                                                                                                             [U][CO2]   
          

                [4 x 5= 20] 

 

 

 

 
Part C 

Essay Questions 

Answer 2 Questions 

Each question carries 10 marks 

 

17. Create an HTML code for the given table as shown below             [U][CO1] 
 

Course BCA MCA 

Boys 
55 40 

50 45 

Girls 
50 40 

45 40 

18. Explain various form controls (like <input>, <select>, and <textarea>) used in the <form> 

tag with an example.         [U][CO2] 

19. Illustrate with an example to show how external, internal and inline style sheets contribute 

to web designing.        [A][CO3] 
                   [2 x10 = 20] 



MAHATMA GANDHI UNIVERSITY, KOTTAYAM 

MGU-UGP (HONOURS) 

FIRST SEMESTER EXAMINATION 

(2024 ADMISSION ONWARDS) 

MG1DSCCSC100- Art of Computing and Problem Solving 

Duration: 1.5 hrs                Maximum Marks: 50 

Students should attempt atleast one question from each course outcome to enhance their 

overall outcome attainability. 

Part A 

Very Short Answer Questions 

Answer All Questions 

Each question carries 1 mark 

 

1. If a computer has 16 MB of RAM, how many bytes of data can it hold?   [U][CO1] 

2. You are using a computer to create a presentation for a meeting while also checking your 

email. What type of software are you using in each case, and why? [U][CO1] 

3. Name the translator that translates source code line by line during execution. [K][CO1] 

4. Identify the errors in the following code. [U][CO1] 

             int main(); 

             {  

              for (int i = 0, i < 10, i++);  

              printf("%f\n", i);  

              return 0;  

             }  

5. The identifier ‘sum’ is not equal to ‘SuM’. Justify your answer.  [U][CO2] 

6. Identify a data type in C that signifies the absence of a value or null. [K][CO2] 

7. Which header file includes the declaration for the printf() function in C?       [K][CO2] 

8. Write the output of the following program segment? [A][CO3] 

int i = 0; 

while (i <= 10)  

{ 

printf("%d\n", i+2); 

}   

9. A function is defined to calculate the factorial of a number and return the result to the 

calling function. What return type should be used in the function prototype?  [A][CO3] 

10. A program requires checking if two user-entered email addresses are the same during 

registration. Which string function would you use to compare the two email addresses in 

C? [A][CO3] 

 

[1 x 10 = 10] 

 

 

 



Part B 

Short Answer Questions 

Answer 4 Questions 

Each question carries 5 marks 

 

11. Discuss the features of high-level languages that make them more user-friendly compared 

to assembly language.  [U][CO1] 

12. In a distance conversion program, you are asked to convert a distance from kilometers to 

miles. The formula for conversion is miles=kilometers×0.621371. Using this formula, 

identify the constants and variables. Explain the role of each in the conversion process.

 [U][CO2] 

13. Draw a flowchart to find the largest among three numbers. [U][CO1] 

14. Compare the pre-increment operator (++x) and the post-increment operator (x++) in C 

programming. Demonstrate how the results differ when both operators are used in 

expressions. [U][CO2] 

15. Consider a scenario where you need to store the heights of players on a basketball team for 

analysis (for e.g., 12 players). Which data structure would you choose to store these height 

values in C? How would you declare and initialize this data structure? Write code to 

calculate and display the average height of the players on the team. [A][CO3] 

16. Create a program that categorizes customer feedback ratings for a product based on the 

following criteria: 

• Rating '5' indicates "Outstanding." 

• Ratings '4' and '3' indicate "Satisfactory." 

• Ratings '2' and '1' indicate "Needs Improvement." 

Implement this categorization using a switch-case statement. Ensure that the program 

prompts the user to enter a rating and displays the corresponding feedback category. 

 [A][CO3] 

 

[5 x 4 = 20] 

 

Part C 

Essay Questions 

Answer 2 Questions 

Each question carries 10 marks 

 

17. Explain the problem-solving life cycle and provide an example to illustrate each step. 

 [U][CO1] 

 

18. Discuss one entry-controlled loop in C. Write a C program that generates and prints the 

Fibonacci series up to a specified number of terms using a while loop. The Fibonacci series 

is defined as follows: 

• The first two terms are 0 and 1. 

• Each subsequent term is the sum of the two preceding terms. 

Requirements: 

1) Prompt the user to enter the number of terms in the Fibonacci series (must be a positive 

integer). 

2) Calculate and print the Fibonacci series up to the specified number of terms.  [A][CO3] 



19. Write the purpose of using 'nested if' statements in a program. Write a nested if statement 

to determine the discount amount in the following scenario. 

 

A tech store is offering discounts based on customer membership status (Member or Non-

Member) and the category of electronics (Laptops, Tablets, or Accessories). 

The discount rules are as follows: 

 

Members: 

Laptops: 25% discount. 

Tablets: 15% discount. 

Accessories: 10% discount. 

 

Non-Members: 

Laptops: 10% discount. 

Tablets: 5% discount. 

Accessories: No discount. 

 

The program should ask the customer to input their membership status and the category of 

electronics, then calculate and display the discount amount. [A][CO3] 

 

[10 x 2 = 20] 

 

 



MAHATMA GANDHI UNIVERSITY, KOTTAYAM 
 

MGU-UGP (HONOURS) 

 FIRST SEMESTER EXAMINATION 

(2024 ADMISSION ONWARDS) 

MG1DSCECC102 – Computer Fundamentals 

Duration: 1.5hrs Maximum Marks: 50 

Students should attempt atleast one question from each course outcome to enhance their overall outcome 

attainability. 

 
Part A 

Very Short Answer Questions 

Answer All Questions 

Each question carries 1 mark 

1. Imagine you are a researcher using a supercomputer to analyse climate data. Name two different 

optimising methods to improve the data quality and integrity.                                                        [U][CO1] 

2. I can manage the activities of the computer hardware and interact with the application software to 

perform a particular task. Who am I?                                                                                  [U][CO1] 

3. A computer system frequently accesses the same data during processing. What type of memory helps to 

reduce access time for this data?                                                                                                [U][CO1] 

4. List the phases of an execution cycle.                                                            [K][CO1] 

5. Write the purpose of IRG on magnetic tape.                                                                                   [K][CO2] 

6. Identify the mechanism used in optical storage devices to retrieve and store data.                        [U][CO2] 

7. You need to type special characters ($ or %) in a document. Write the name of this key.          [U][CO3] 

8. While printing non-impact printers do not produce much noise, why?                               [U][CO3] 

9. Identify the use of a portable projector.                               [U][CO3] 

10. After a photo shoot, you plan to review your images using the live preview function. Name the digital 

camera used for this purpose.                                                                                            [U][CO3] 

[1 x 10 = 10 marks] 

Part B 

Short Essay Type Questions 

Answer any 4 Questions 

Each question carries 5 marks 

11. Summarize how computer dependency can negatively affect a person’s life. What evidence supports this 

claim?                                                         [U][CO1] 

12. Define bus. List the different types of buses on the computer.                                         [K][CO1] 

13. Write the characteristics of a memory device and how these characteristics affect overall system 

efficiency.                                         [U][CO2]         

14. In your own words, explain how magnetic tape technology can be used for data backup and archiving.

                                          [U][CO2] 

15. Relate the trackball with the mechanical mouse using an example.                                        [U][CO3]  

16. Identify the key classifications of terminals in computing, and how each type serves distinct purposes

                          [5 x 4 = 20 marks] 

 

 

 

 

 



Part C 

Essay Type Questions 

Answer any 2 Questions 

Each question carries 10 marks 
 

17. Demonstrate the role of buses in processor-to-memory communication with a block diagram. How do 

the address, data, and control buses work together to facilitate data transfer?                            [U][CO1] 

 

18. Identify the various types of ROM and describe how their read and write capabilities influence their 

applications in technology.                                                                                                           [U][CO2] 

19. Describe different input devices used generally in media to communicate with mass audiences.  

                                                                    [U][CO3]                         

[10 x 2 = 20 marks] 



MAHATMA GANDHI UNIVERSITY, KOTTAYAM 

MGU-UGP (HONOURS) 

FIRST SEMESTER EXAMINATION 

(2024 ADMISION ONWARDS) 

MG1DSCECT101 - COMPUTER FUNDAMENTALS AND BASICS OF PC HARDWARE 

Duration: 1.5 hours Maximum Marks: 50 

Students should attempt at least one question from each course outcome to enhance their overall 

outcome attainability. 

*Remember (K), Understand (U), Apply (A), Analyse (An), Evaluate (E), Create (C) 

 

Part A 

Multiple Choice Questions 

Answer All Questions 

Each question carries 1 mark 

1 Identify the primary function of the Central Processing Unit (CPU) from the given list. 

a) Data Storage b) input/output operations c) Executing instructions d) Networking 

 

U 

 

1 

2 Identify the primary function of the ENIAC computer. 

a) To perform simple calculations b) To solve complex mathematical problems 

c) To store data d) To run commercial applications 

 

U 

 

1 

3 Identify the no: of unique characters that can be represented with 7 bits in ASCII. 

a) 64 b)128 c)256 d)512 

U 1 

4 Name the device which is typically used to connect different networks in a WAN. 

a) Hub b) Switch c) Router d) Repeater 

K 1 

5 Identify the act of retrieving data from a memory storage location 

a) Memory Write b) Backup c) Formatting d) Memory Read 

U 2 

6 Classify the secondary storage device best suited for long-term archiving of data. 

a) RAM b)SSD c)HDD d)Optical Disc 

U 2 

7 Indicate which option identifies the primary function of a mouse. 

a) To enter text b) To move the cursor and select items on the screen 

c) To print documents d) To process images 

 

U 

 

2 

8 Compare the advantages of SSDs over HDDs in data retrieval during multitasking. 

a) HDDs retrieve data faster during multitasking due to their larger capacity. 

b) SSDs and HDDs offer similar performance in multitasking environments. 

c) SSDs have faster data retrieval, enhancing multitasking performance. 

d) HDDs have better performance due to their mechanical components. 

 

 

An 

 

 

3 

9 Examine the effects of using multiple GPUs in a system and identify the primary advantage. 

a) It reduces the need for cooling solutions b) It enhances performance of graphics 

c)It simplifies the system architecture d) It decreases power consumption 

 

An 

 

3 

10 Examine which type of cache writing strategy updates data in both the cache and the 

main memory simultaneously. 

a) Cache overflow b) Cache hit c) Cache miss d) Cache bypass 

 

An 

 

3 

 

1 * 10 = 10 

 

 

 

 

 



Part B 

Short Answer Questions 

Answer 4 Questions 

Each question carries 5 marks 

 

11 Discuss why memory management function of operating system is important. U 1 

12 Distinguish between hardware and software in a computer system. U 1 

13 Explain what registers are. Discuss the important registers used in CPU. U 2 

14 Describe the different types of printers available and identify the advantages and 

disadvantages of each type. 
U 2 

15 Explain Green Computing with an example. An 3 

16 Predict the potential benefits of neuromorphic computing in replicating human 

brain functions. 
An 3 

 

4 * 5 = 20 

 

Part C 

Essay Questions 

Answer 2 Questions 

Each question carries 10 marks 

 

17 Describe the components of a computer system with a simple diagram to support 

your explanation. 
U 1 

18 Describe how the core functions of OS contribute to the overall system 

performance. 
U 1 

19 Explain the differences between various types of USB ports & CPU Sockets. U 2 

20 Differentiate Virtual Reality (VR) and Augmented Reality (AR) in terms of user 

experience and applications. 
An 3 

 

2 * 10 = 20 



 

MAHATMA GANDHI UNIVERSITY, KOTTAYAM 

MGU-UGP (HONOURS)  

FIRST SEMESTER EXAMINATION  

(2024 ADMISSION ONWARDS)  

MG1MDCCSC100– Cyber Laws and Online Safety 

 
Duration: One hour                                                                                                                Maximum Marks: 35  

 

Students should attempt at least one question from each course outcome to enhance their overall 

outcome attainability.  

Part A  

Very Short Answer Questions  

Answer All Questions  

Each question carries 1 mark 

 

1. When was the IT Act 2000 enacted?              [K] [CO1] 

2. Expand GDPR.                  [K] [CO1] 

3. Identify the section of IT Act that deals with cyber fraud.                         [U] [CO1] 

4. Differentiate cybercrimes and traditional crimes.            [U] [CO1] 

5. How do the victims of cyberbullying report incidents in India?          [K] [CO1] 

6. Define the Principle of Confidentiality             [K] [CO2] 

7. What does MFA stand for in cybersecurity?            [K][CO2] 

8. Name One sign of Phishing mail.             [U][CO2] 

9. Recall a Skimming device.              [K][CO2] 

10. Write about encryption.              [U][CO2] 

 

                                     [1 x 10 = 10 marks]  

Part B 

Short Essay Type Questions  

Answer any three Questions  

Each question carries 5 marks 

 

11. Discuss the key legal concepts in cyberspace.                                            [U][CO1] 

12. Indicate the provisions for data protection introduced in the 2008 amendment.       [U][CO1] 

13. Explain cyber fraud, and how the IT Act tackle this crime.                                                 [U][CO1] 

14. Analyze the significance of regular software updates in maintaining internet security. 

                                                                                              [U][CO2] 

15. “Over-sharing information on social media can lead to security vulnerabilities and identity 

theft”. Is the statement correct? Justify your answer.                                                        [An][CO2] 

                            [5 x 3 = 15 marks] 

 

 



 

Part C 

Essay Type Questions  

Answer any one  

Each question carries 10 marks 

 

16.    Discuss the key provisions and legal implications of the IT Act 2000 related to cybercrimes. 

How does the Act address unauthorized access, hacking, and cyber fraud?                [U][CO1] 

17.   Discuss a real-world cyberattack or security breach that involved weak passwords, poor 

internet security practices, or social engineering. Analyze the impact of the attack and what 

could have been done to prevent it.                                                                       [An][CO2] 

              [10 x 1 = 10 marks] 



MAHATMA GANDHI UNIVERSITY, KOTTAYAM 

MGU-UGP (HONOURS) 

FIRST SEMESTER EXAMINATION. (2024 ADMISSION ONWARDS) 

MG1MDCCSC101– Internet and Web Technologies 

   Duration: 1 hour                      Maximum Marks: 35 

Students should attempt at least one question from each course outcome to enhance their overall 

outcome attainability. 

Part A 

Very Short Answer Questions.  Answer All Questions. Each question carries 1 mark  

1. List the fundamental components that make up a computer network.                              [K][CO1] 

2. List the six levels of HTML headings.                     [K][CO2] 

3. State the purpose of HTML.                       [K][CO2] 

4. What is a Metropolitan Area Network (MAN)?                                 [K][CO1] 

5. Name the HTML element that defines text tracks in media players.                   [K][CO2] 

6. State the primary function of DNS in internet communication.                  [U][CO1] 

7. Identify two search engines.                       [U][CO1] 

8. Name any four input elements in a <form> tag of HTML.                   [U][CO2] 

9. Differentiate HTTP and HTTPS.                       [U][CO1] 

10. Which attributes are used to determine the size of an image thumbnail?                         [U][CO2] 

                              (1*10=10 Marks) 

Part B 

Short Answer Questions. Answer any 3 out of 5 Questions.  Each question carries 5 marks. 

11. Describe the concept of a computer network. What are its key components                     [U][CO1] 

12. How do a hub and a switch differ in terms of their functionality, data handling, and efficiency in 

a network?                                                                          [U][CO1] 

13. How would you describe the attributes that help define the size of an image thumbnail? [U][CO2] 

14. Explain the purpose and usage of the <h1> to <h6> tags and the <p> tag in HTML?      [U][CO2] 

15. Describe the main purpose of the <frameset> tag in HTML.                                            [U][CO2] 

                                 (3*5=15 Marks) 

Part C 

Essay Questions. Answer any 1 out of 2 Questions. Each question carries 10 marks. 

 

16.  Explain the differences among popular audio formats like MP3, WAV, and OGG?     [U][CO2]                                                                                                                                         

17.  Describe different applications of the internet                                                                [U][CO1] 

                                                                                                                       (1*10=10 Marks) 
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