
MAHATMA GANDHI UNIVERSITY, KOTTAYAM  

MGU-UGP (HONOURS)  

SECOND SEMESTER EXAMINATION  

(2024 ADMISION ONWARDS) 

MG1MDCECT101 – Python for Electronics 

Duration: 1.5 hour                   Maximum Marks: 35 

PracticalExamination–ModelQuestionPaper 

Instructions: 

 Demonstratethegiventask 
 Viva session (Minimum 5 questions from the practicalmodule) 
 LabReport 

EvaluationCriteria: 

 Viva:7 marks 
 LabReport:8marks 
 Demonstration:20marks 

Tasks:(Chooseanyone) 

1. Given a List of Radii of circles. Write a Python program to find the area and 
circumference. Print these as a list 

2.  Given a List of length of squares. Write a Python program to find the area and perimeter. 
Print these as a list 

3. Given a two Lists of length and breadth of rectangles. Write a Python program to find the 
area and perimeter. Print these as a list 

4. Find the sum of the first 100 numbers using for loop 

5. Find the sum of square of the first 100 odd numbers using for loop 

6. Find the sum of square of the first 100 even numbers using while loop 

7.  Given a string. Find the number of characters in the string. Print the result. If it is even 
print “The length is even”, else print “The length is odd” 

8.  Given a string. Get thestring in the reverse order 

9. Given a string. Get the odd index characters in the string 

10. Given a string. Get the even index characters in the string 

11. Find the sum of square of the first 100 multiples of 5 using while loop 

12. Given a string, get all the characters in lower case and upper case 

13. Given a string, get the middle of the string in upper case. 



MAHATMA GANDHI UNIVERSITY, KOTTAYAM  

MGU-UGP (HONOURS) 

SECOND  SEMESTER EXAMINATION 

(2024 ADMISION ONWARDS) 

MG2DSCECT100 Essential Concepts in Digital Electronics  
 

Duration: 1.5 hours                    Maximum Marks: 50 

Students should attempt atleast one question from each course outcome to enhance their 
overall outcome attainability.  

*Remember (K), Understand (U), Apply (A), Analyse (An), Evaluate (E), Create (C), Skill 
(S), Interest (I) and Appreciation (Ap) 

 
Part A  

Multiple Choice Questions  
Answer All Questions  

Each question carries 1 mark  
1 What is the decimal equivalent of the binary number 1011? 

a) 9     b) 10        c) 11           d) 12 
U CO1 

2 What is the output of an AND gate if both inputs are 1? 
a) 0      b) 1              c) 2             d) Undefined 

K CO2 

3 Which of the following gates is known as a universal gate? 
a) AND         b)OR         c) NOT              d)NAND 

K CO2 

4 What is the main characteristic of a flip-flop? 
a) It stores binary data   b) It performs arithmetic operations 
c) It converts binary data to decimal    d) It amplifies signals    

K CO3 

5 Which of the following is the Boolean expression for the Sum output of 
a Full Adder? 
a) A ⊕ B ⊕ Cin  b) (A + B) ⊕Cin c) (A * B) ⊕ Cind) A + B + Cin 

K,
U 

CO3 

6 Which of the following is a characteristic of a shift register? 
a)Store data in sequence  b) Perform logical operations 
c) Convert analog to digital signals d) Amplify weak signals 

K CO3 

7 The Karnaugh map (K-map) is used for: 
a)Simplifying Boolean expressions b) Converting binary numbers 
c) Generating truth tables    d) Analyzing circuit diagrams 

U CO2 

8 What is the binary form of the hexadecimal number A? 
a) 1011 b) 1100 c) 1010 d) 1001 

K CO1 

9 Which of the following is the result of the Boolean expression A + 𝐴̅𝐵? 
a) Ab) A + B c) A' d) A'B 

U CO2 

10 Which Boolean expression is in canonical SOP form? 
a) A'B + AB' b) A + B c) AB d) A + A'B 

U CO2 

 
1 * 10 = 10 



Part B 
Short Answer Questions  
Answer any4 Questions  

Each question carries 5 marks  
 

11 Explain the operation of a Half Adder and a Full Adder. Draw their 

logic diagrams and truth tables. 

U CO3 

12 Simplify the following Boolean expression using a Karnaugh Map: 

F(A, B, C) = Σ(1, 3, 5, 7) 

U CO2 

13 Convert the following numbers: 

a) Binary 101110 to Decimal 

b) Decimal 45 to Binary 

c) Octal 12 to Decimal 

Explain the steps involved in each conversion. 

K CO1 

14 Explain the basic logic gates (AND, OR, NOT) with their symbols and 

truth tables. Also, show the truth table for a NAND gate and explain its 

operation. 

K CO2 

15 Convert   the following hexadecimal number to decimal 

a) E5                                  b) A85 

U CO1 

16  Express the decimal number -39 as an 8 bit number in the sign 
magnitude. 1’s complement and 2’s complement 

U CO1 

4 * 5 = 20 
Part C 

Essay Questions  
Answer any2 Questions  

Each question carries 10 marks  
17  a) Discuss the different types of logic gates, with their truth tables and   

symbols? 
b) write the laws and rules of Boolean algebra? 

K CO2 

18 Simplify the following Boolean expressions using K-map 

a)A′B′C′D+AB′C′D+ABC′D+ABC′D′ 

b)A′B′C+AB′C′+AB′C+A′BC′ 

U CO2 

19 a) Determine the binary number for the following hexadecimal number 
I) 10A4        II) CF8E               III) 9742 
b) Convert the following octal number to decimal              
 I) 1024              II) 7765 

U CO1 

20 Explain the working principle of aRing Counter. K CO3 

 
2 * 10 = 20 
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*Remember (K), Understand (U), Apply (A), Analyse (An), Evaluate (E), Create (C), Skill (S), 

Interest (I) and Appreciation (Ap) 
 

Students should attempt at least one question from each course outcome to enhance their 
overall outcome attainability 

 
PartA 

MultipleChoiceQuestions 
Answer All Questions 

Eachquestioncarries1mark 

Write complete answers of your choice in the answer paper against each question number 

 
1. Identifythetransmissionmodethatallowsdatatoflowinbothdirectionsbutonlyonedirectionata 

time.[U][1] 
a) Simplex b)HalfDuplex c)FullDuplex d)Multiplexing 

2.Whatunitisusedtomeasurethebandwidthofasignal? [U] [1] 
a)Bitrate b)Baudrate c)Hertz d)Decibel   

3.Whatistheprimaryfunctionofarepeaterinadatacommunicationsystem? [U] [1] 
 a)Amplifyingdatasignals   
 b)Encodingdata   

 c)Multiplexingdata   

 d)Filteringdata   

4. Thermalnoiseisintroducedbywhichfactorinacommunicationsystem? [U] [1] 

a)Impulsenoise b) Crosstalk c)Thermal noise d)Intermodulationnoise 
5. Amongguidedmedia,whichoneprovidesthehighestdatatransmissionrate? [U] [2] 

a) STPb)UTP c)Coaxialcable d)Fiberopticcable 
6. Identifythewirelesstransmissionmediumthatreliesonline-of-sightcommunication[U] [2] 

a) Infrared b)Radiowavec)Satellitemicrowaved)Fiberopticcable 
7.HowdoesAmplitudeShiftKeying(ASK)representdigitaldata? [U] [3] 

a)Byvaryingtheamplitudeofthecarriersignal   

b)Bychangingthefrequencyofthecarriersignal   



c)Bymodifyingthephaseofthecarriersignal   

d)Bycombiningamplitudeandphasechanges   

8.WhatprincipledoesPhaseShiftKeying(PSK)relyonfordatatransmission? [U] [3] 
a)Amplitudevariation   

b)Frequencymodulation   

c)Phasechanges   

d)Timedivision   

9.Choosethemultiplexingtechniquecommonlyusedinfiberopticcommunication?   

a)FDM b)TDM c)WDM d)FHSS [U] [3] 
10.Themodulationtechniquepreferredforlong-distanceanalogsignaltransmissionis [U] [3] 

a) AmplitudeModulation 
b) FrequencyModulation 
c) PhaseModulation 
d) DeltaModulation 

(1 x 10 = 10) 
PartB 

ShortAnswerQuestions 
Answer Any 4 Questions 

Each question carries 5 marks 
 

11. Withthehelpofablockdiagramexplainthefivecomponentsinvolvedinacommunicationsystem.[U][1] 

12. Distinguishbetweenhalf-duplexandfull-duplextransmissionmodes? [U] [1] 

13. Describethestructureofacoaxialcableanditsapplicationsindatacommunication.[U][2] 

14. Howdoesskypropagationdifferfromline-of-sightpropagation? [U] [2] 

15. Comparesynchronousandasynchronoustransmission . [U] [3] 

16. Explainfrequencyshiftkeying [U] [3] 

 
(4 x 5 = 20) 

 
PartC 

EssayQuestions 
AnswerAny 2Questions 

Each question carries 10 marks 

 
17. Explainthedifferenttypesoftransmissionimpairmentsindatacommunicationandtheireffects. 

 [U] [1] 
18. ComparePulseCodeModulationandDeltaModulation[U][2] 

19. DescribetheworkingofFrequencyHoppingSpreadSpectrum(FHSS)andDirectSequenceSpread 

Spectrum (DSSS) techniques with their advantages.[U][3] 

 

(2 x 10 =20) 
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Part A  

Multiple Choice Questions  
Answer All Questions  

Each question carries 1 mark  
 

1 Which of the following best defines Artificial Intelligence (AI)? 
a) The ability of machines to perform tasks without human intervention 
b) A branch of computer science that aims to create intelligent machines 
c) A software program that mimics human behavior 
d) A set of rules followed by a computer 

K 1 

2 What is a key characteristic of neural networks in machine learning? 
a) They are rule-based systems   b) They process information in layers 
c) They do not require large datasets  d) They work only with structured data 

U 1 

3 Which of the following is NOT a type of machine learning system? 
a) Supervised Learning      b) Reinforcement Learning 
c) Predictive Learning        d) Unsupervised Learning 

U 1 

4 Which library is commonly used to extract data from a MySQL database in 
Python? 
a) NumPy             b) Matplotlib              c) Pandas            d) TensorFlow 

K 2 

5 Which Python library is commonly used to extract data from a database? 
a) pandas      b) matplotlib       c) numpy            d) seaborn 

U 2 

6 Which of the following is NOT a valid way to run Python code? 
a) Jupyter Notebook     b) Pycharm        c) Microsoft Excel     d) IDLE 

K 2 

7 In Gradient Descent, what does the learning rate control? 
a) The number of neurons     b) The size of the step taken towards the minimum 
c) The number of features in the dataset    d) The type of activation function used 

U 2 

8 In reinforcement learning, the system learns by: 
a) Finding hidden patterns in unlabeled data    
b) Comparing its predictions with true labels 
c) Receiving rewards or penalties for actions taken 
d) Assigning data points to clusters 

K 3 

9 Which of the following is a type of regression analysis? 
a) Hierarchical clustering  b) Decision trees  c) Linear regression  d) SVM 

U 3 

10 Which of the following is an example of supervised learning? 
a) K-Means Clustering    b) Principal Component Analysis 
c) K-Nearest Neighbors (KNN)   d) Hierarchical Clustering 

U 3 

 
1 * 10 = 10 



Part B 
Short Answer Questions  
Answer any 4 Questions  

Each question carries 5 marks  
 

11 Mention two major challenges in implementing machine learning models. U 1 

12 What are variables in Python? Give an example. A 2 

13 What is the primary purpose of the gradient descent algorithm? U 2 

14 Explain the working principle of Hierarchical Clustering with an example. A 3 

15 What is the purpose of regression analysis in machine learning? U 3 

16 What is the primary difference between supervised and unsupervised 

machine learning? 

U 3 

 
4 * 5 = 20 

 
Part C 

Essay Questions  
Answer any 2 Questions  

Each question carries 10 marks  
 

17 Explain the different types of machine learning systems with examples. U 1 

18 Discuss the applications of machine learning in medical treatment and 

business, highlighting their impact. 

U 1 

19 Describe Python’s control flow statements (if-elif-else, loops) with syntax 

and examples. 

A 2 

20 Describe the working of K-Nearest Neighbors (KNN) and its applications 

in machine learning. 

U 3 

2 * 10 = 20 
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Part A  

Multiple Choice Questions  
Answer All Questions  

Each question carries 1 mark  
 

1 In a comparator circuit, when the non-inverting input voltage is higher than 
the inverting input voltage, the output will be: 

A) High                    B) Low                C) Zero                  D) Undefined 

 
 

U 

 
 

CO1 
2 What is the main function of an Operational Amplifier  

A) Amplify high-frequency signals 
B) Amplify low-frequency signals 
C) Perform mathematical operations like addition, subtraction, etc. 
D) Convert digital signals to analog signals 

 
 

K 

 
 

C01 

3 The primary purpose of a Unity Gain Amplifier (Buffer Amplifier) using an 
Op-Amp is: 

A) To amplify the input signal with high gain 
B) To provide isolation between different stages of a circuit 
C) To filter the input signal 
D) To oscillate at a fixed frequency 

 
 

U 

 
 

C01 

4 The primary function of a Schmitt Trigger is 
A) To amplify a signal without distortion 
B) To convert a sinusoidal signal into a square wave 
C) To filter high-frequency noise from a signal 
D) To regulate the output voltage 

 
 

U 

 
 

CO2 

5 What does a capacitor filter do in a power supply?   
A) Increase the voltage                B) Smooth the output voltage  
C) Decrease the current               D) Store electrical energy  

 
 

U 

 
 

C02 
6 What is the primary function of a 78XX voltage regulator IC  

A) To increase voltage 
B) To provide a constant output voltage  
C) To store electrical energy 
D) To convert AC to DC  

 
 

U 

 
 

CO2 

7 The output waveform of a bridge rectifier is 
A) A pure sinusoidal waveform             B) A smooth DC signal 
C) A pulsating DC signal                       D) An inverted AC waveform 

 
 

K 

 
 

CO2 



8 In a Brushless DC motor, the rotor contains which of the following? 
A) Permanent magnets           B) Induced electromagnets 
C) Copper windings               D) Brushes 

 
 

U 

 
 

CO3 
9 In an induction motor, what is the relationship between the speed of the rotor 

and the synchronous speed? 
A) The rotor speed is always higher than the synchronous speed 
B) The rotor speed is always equal to the synchronous speed 
C) The rotor speed is always lower than the synchronous speed 
D) The rotor speed is independent of synchronous speed 

 
 

A 

 
 

CO3 

10 What type of current is delivered to the battery in DC fast charging?  
A) Alternating Current (AC)    B) Direct Current (DC)  
C) Pulsating Current                    D) Inductive Current 

 
 

K 

 
 

CO3 
 

1 * 10 = 10 
Part B 

Short Answer Questions  
Answer any4 Questions  

Each question carries 5 marks  
 

11 What is the gain of an inverting amplifier if𝑅௙=10K 𝑎𝑛𝑑 𝑅௜௡ =1K U CO1 

12 What is an LDR. Explain with proper circuit diagram to amplify the signal 

from LDR using op-amp 

U CO1 

13 Draw the output waveform of a Schmitt trigger when𝑉௎் =2V and 𝑉௅்= - 2V U CO2 

14 What is a bridge rectifier.How does it convert AC voltage to DC voltage 

using diodes? 

U CO2 

15 What is a Battery Management Unit (BMU)? A CO3 

16 What is commutation. How is it achieved in a BLDC motor A CO3 

 
4 * 5 = 20 

 
Part C 

Essay Questions  
Answer any2 Questions  

Each question carries 10 marks  
 

17 Explain the working of a non-inverting amplifier with proper circuit diagram. 

Write the gain formula of non-inverting amplifier 

K CO1 

18 How we can use an IC 741 as a zero-crossing detector. Explain with proper 

circuit diagram and also draw the input and output waveforms 

U CO2 

19 With the help of block diagrams explain the working of SMPS  U CO2 

20 Explain the working of BLDC motor. Why it is called brushless A CO3 

 
2 * 10 = 20 
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Students should attempt at least one question from each course outcome to enhance their overall 
outcome attainability 

 
Part A  

Multiple Choice Questions  
Answer All Questions  

Each question carries 1 mark  
 

1 Which of the following is a primitive data type in Dart? 

A) ListB) int  C) MapD) Set 

[U] 

 

CO1 

2 Which plugin is required for Visual Studio Code to support Flutter development? 

A) Flutter and DartB) Android and Dart 

C) Flutter and JavaD) Dart and Kotlin 

[U]  CO2 

3 Which of the following is a local storage solution in Flutter?  

a) SQLite b) Firestore c) Firebase Realtime Database d) Cloud Storage 

[K] CO3 

4 What is the purpose of null in programming? 
A) It represents an undefined value        B) It stores integers 
C) It performs arithmetic operations       D) It represents a list 

[K] CO1 

5 Which command is used to create a new Flutter project? 

A) flutter startB) flutter create 

C) flutter newD)flutter init 

[U]  CO2 

6 Which operator is used for modulus operation? 
A) %                    B) /                            C) //                                  D) ^ 

 

[K] 

 

CO1 

7 Which Firebase service is used for storing large files such as images and videos? [K] CO3 



A) FirestoreB) Firebase Storage 

C) Firebase AuthenticationD) Firebase Cloud Functions 

8 Which package provides widgets that follow Android design principles? 
A) Cupertino                                        B) Material 
C) Bootstrap                                         D) Tailwind 

[U] CO2 

9 Which HTTP method is used to retrieve data from a RESTful API? 

A) POST                   B) GET              C) PUT                       D) DELETE 

[U] CO3 

10 Which command is used to run a Flutter app on an Android emulator or device? 

A) flutter build apkB) flutter runC) flutter startD) flutter launch 

[U] CO2 

 
(1 x 10 = 10) 

 
Part B 

Short Answer Questions 
Answer 4 Questions 

Each question carries 5 marks 
 

11 Explain the various data types in Dart and also Provide examples of how 
each data type is used in a Flutter application. 

[U] CO1 

12 Name three commonly used Material widgets in Flutter and their purposes. [U] CO2 
13 What is a class in Dart, and how is it different from an object? [U] CO1 
14 What is the importance of SQLite used for in Flutter? [U] CO3 
15 Explain the difference between StatelessWidget and StatefulWidget in 

Flutter.  
[U]  CO2 

16 What is the difference between Firestore and Firebase Realtime Database? [U] CO3 
 

(4 x 5 = 20) 
 

Part C 
Essay Questions 

Answer 2 Questions 
Each question carries 10 marks 

 
17 What are collections in Dart? Explain List, Map, and Set with examples. [U] CO1 

18 Explain the different data types available in Dart with examples. [U] CO1 

19 Explain different data storage options available in Flutter. [U]  CO3 

20 Explain different types of data storage in Flutter, focusing on SQLite and 
SharedPreferences. 

[U] CO2 

 
(2 x 10 = 20) 
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Students should attempt at least one question from each course outcome to enhance their overall 

outcome attainability.  
 

Part A  
Multiple Choice Questions 
 Answer any 35 questions 

 Each question carries 1 mark 

Write complete answers of your choice in the answer paper against each question number 
 
 

1 What does IoT stand for? 
a) Internet of Thingsb) Integration of Technology 
c) Intelligent Online Trackingd) Internet of Technology 

K 1 

2 Which statement best defines the Internet of Things (IoT)? 
a) A collection of unrelated devices without communication 
b) A system where devices collect and exchange data via the internet 
c) A type of web browser 
d) A new social media platform 

U 1 

3 Who is credited with coining the term "Internet of Things"? 
a) Tim Berners-Leeb) Kevin Ashton 
c) Elon Muskd) Bill Gates 

K 1 

4 What is a key characteristic of IoT devices? 
a) They must always require human intervention to function 
b) They collect, share, and analyze data automatically 
c) They work only with Bluetooth connections 
d) They are limited to home automation applications 

K 1 

5 How does IoT help in precision farming? 
a) By collecting real-time data on soil moisture, weather, and crop health 
b) By replacing human farmers entirely 
c) By automating only the sale of crops 
d) By eliminating the need for fertilizers 

R 1 

6 What role do sensors play in IoT? 
a) They store data permanently 

K 1 



b) They collect real-time data from the environment 
c) They act as display screens for IoT devices 
d) They provide only power to IoT systems 

7 What is the primary function of a microcontroller in an IoT system? 
a) To provide power to sensors 
b) To process sensor data and control connected devices 
c) To function as a storage device 
d) To act as a wireless communication module 

U 1 

8 Which feature of microcontrollers makes them ideal for IoT applications? 
a) High power consumptionb) Large display screens 
c) Low power consumption and real-time processing capabilities 
d) Ability to run complex video games 

U 1 

9 What is the primary function of a sensor in IoT? 
a) Generate electrical powerb) Collect data from the environment  
c) Store data permanentlyd) Control mechanical devices 

U 1 

10 What is the first step in IoT data collection? 
a) Processingb) Sensing  
c) Transmissiond) Storage 

K 1 

11 How can soil moisture sensors help in farming? 

a) Reduce water wastage b) Reduce soil erosion 

c) Decrease plant growthd) Increase pesticide use 

U 1 

12 Which of the following is a commonly used temperature sensor? 

a) LM35 b) PIR sensor 

c) Soil moisture sensord) Gas sensor 

K 1 

13 What do humidity sensors measure? 

a) Water vapor in the air b) Soil moisture 

c) Wind speedd) Pressure 

U 1 

14 Which of the following is NOT an example of an actuator? 

a) Servo motorb) Relay 

c) LEDd) Microcontroller  

U 1 

15 What type of actuator is used in automated irrigation? 

a) Solenoid valve b) Speaker 

c) Light sensord) Thermistor 

K 1 

16 What type of actuator is commonly used in robotic arms? 

a) Stepper motorb) Ultrasonic sensor 

c) Thermistord) Light sensor 

K 1 

17 What does IoT stand for? 
a) Internet of Thingsb) Internet of Technology 
c) Integration of Thingsd) Internet of Tasks 

K 1 

18 Which of the following is a communication protocol commonly used in IoT 
networks? 
a) HTTPb) Zigbee 
c) USBd) HDMI 

K 1 

19 What is Zigbee primarily used for? 
a) High-speed internet communication 

U 1 



b) Long-distance communication 
c) Short-range wireless communication in IoT devices 
d) Satellite communication 

20  What is the main advantage of LoRa technology? 
a) High data transfer speeds 
b) Long-range communication with low power consumption 
c) Compatibility with Bluetooth devices 
d) Low cost for short-distance communication 

U 1 

21 Which of the following is essential for plant growth? 
a) Soil, water, and sunlightb) Soil, water, and plastic 
c) Soil, water, and metald) Soil, water, and sand 

K 2 

22 What is the first stage of a plant's life cycle? 
a) Floweringb) Germination 
c) Pollinationd) Fruiting 

K 2 

23 During which stage does a plant develop its roots and first leaves? 
a) Flowering stageb) Germination stage 
c) Pollination staged) Fruiting stage 

K 2 

24 Which of the following is NOT a factor influencing plant health? 
a) Soil qualityb) Amount of sunlight 
c) Type of pot usedd) Water availability 

K 2 

25 What is the primary factor that affects plant yield in agriculture? 
a) The color of the plants      b) Availability of nutrients, water, and sunlight 
c) The height of the plants     d) The number of insects present in the soil 

U 2 

26 Which of the following is a major challenge in traditional farming? 
a) Lack of natural fertilizers  

b) Over-reliance on automated machinery 
c) Dependency on weather conditions and soil quality  

d) Excessive production of crops 

U 2 

27 Why is water conservation important in agriculture? 
a) It helps increase the cost of farming          

b) It prevents soil erosion and ensures sustainability         

c) It reduces the amount of sunlight crops receive 

d) It eliminates the need for irrigation 

U 2 

28 Which of the following is a common problem faced in irrigation? 
a) Excessive rainfall throughout the year       

b) Unequal water distribution and water scarcity       

c) The inability of soil to absorb nutrients       

d) Overuse of artificial lighting in crop production 

U 2 

29 What is a major disadvantage of excessive pesticide usage in farming? 
a) It makes plants grow faster   

b) It leads to soil and water contamination 
c) It completely removes all pests from crops   

d) It improves the taste of fruits and vegetables 

U 2 

30 How does modern agriculture impact the environment? 
a) It always improves soil fertility       

b) It can lead to deforestation, water pollution, and biodiversity loss      

U 2 



c) It eliminates the need for fertilizers 
d) It reduces global temperatures 

31 Which of the following is a significant impact of climate change on agriculture? 
a) More consistent rainfall throughout the year   

b) Increased crop yields in all regions     

c) Unpredictable weather patterns affecting crop growth     

d) Permanent elimination of plant diseases 

U 2 

32 Which modern farming technique helps maximize plant growth with minimal soil 
use? 
a) Traditional plowing                                 b) Hydroponics and aeroponics    

c) Burning of crop residues                         d) Manual seed planting 

U 2 

33 In vertical farming, which of the following is the main advantage of growing 
crops in stacked layers? 

a) It reduces the need for irrigation. 

b) It maximizes land use and allows for year-round crop production.  

c) It eliminates the need for artificial lighting.  

d) It increases the size of the crops produced. 

U 2 

34 In a hydroponic system, what is the primary function of the nutrient solution? 

a) To provide water for the plants.  

b) To deliver essential nutrients directly to the plant roots without soil. 

c) To stabilize the temperature of the growing environment.  

d) To replace the need for artificial lighting. 

U 2 

35 In an aquaponic system, how do fish contribute to plant growth? 

a) Fish waste provides essential nutrients for the plants.  

b) Fish help pollinate the plants.  

c) Fish absorb excess water from the plants.  

d) Fish regulate the temperature of the plants. 

U 2 

36 How does the use of data in farming improve the overall efficiency of 
agricultural practices? 

a) It increases the cost of farming by requiring more machinery.  

b) It allows farmers to monitor and optimize crop health, soil conditions, and 
resource usage.  

c) It completely replaces traditional farming methods.  

d) It eliminates the need for physical labor in farming. 

U 2 

37 In precision agriculture, why is the use of data considered essential for 
enhancing crop yield? 

a) It helps farmers apply water and fertilizers in precise amounts, reducing 
waste.  

b) It helps farmers decide when to harvest without considering crop health.  

c) It ensures that crops are watered uniformly across the entire field. 

d) It replaces traditional farming machinery with fully automated robots. 

U 2 

38 Which of the following is a common method of data collection in IoT-based 
smart farming? 

a) Manual inspections by farmers every few weeks.  

U 2 



b) Wireless sensors for monitoring soil moisture, temperature, and other 
environmental factors. 

c) Using drones exclusively for aerial surveillance.  

d) Collecting data from weather reports alone. 

39 In an IoT-based smart farming system, why is cloud storage commonly used for 
storing farming data? 

a) It allows data to be stored locally on each IoT device for faster retrieval. 

b) It enables centralized data storage that can be accessed remotely for analysis. 
c) It eliminates the need for data analytics in farming.  

d) It provides an unlimited supply of water for the crops. 

U 2 

40 What is the primary purpose of data analytics in IoT-based smart farming? 

a) To reduce the need for human labor in farming operations. 

b) To analyze environmental data and improve decision-making for farming 
practices.  

c) To replace all physical farming equipment with automated systems.  

d) To generate financial reports for farm owners. 

U 2 
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1 Which of the following is correct about Python? 
A) Python is case-sensitive.  
B) Python uses braces {} to define blocks of code.   
C) Python programs must be compiled before running.  
D) Python is only used for web development. 

U CO1 

2 Which of the following is NOT a Python data type? 
A) int     B) float   C)char      D) list 

K CO1 

3 What will `print("I love", "Python", sep="**")` output? 
A) I love**Python B) I love Python  
C)  I lovePythonD )Error 

A CO1 

4 What is the data type of the value 10 in Python? 
A) int          B)float          C) str      D) complex 

A CO1 

5 Which of the following is a valid variable name in Python? 
A) my-var B) my_var C) my var D) my.var 

U CO1 

6 What is the output of the following code? print("5" + "5") 
A) 10          B) 55       C) Error         D) None of the above 

E CO1 

7 Which of the following will raise an error? 
A)  int("5")          B)  float("5.5")        C) int("5.5")         D)float(5) 

An CO1 

8 What is the result of print(round(3.75))?      
A) 3 B) 4 C) 3.7 D) 3.8 

E CO1 

9 Which of the following is the correct way to declare a multi-line string in 
Python? 
A) "This is a multi-line string"             
B) '''This is a multi-line string''' 
C) "This is a multi-line string" (split with \) 
D) b"This is a multi-line string" 

U CO1 



10 What will lst[2:5] return for lst = [100, 200, 300, 400, 500]? 
A)[300, 400, 500]      B) [200, 300, 400]  
C) [300, 400]  D)[200, 300] 

A CO1 

11 What is the output of len([1, 2, 3, 4, 5])?  
A) 4 B)5 C)6 D)Error 

U CO1 

12 How can you create a tuple with a single element? 
A) (5)      B) (5,)     C) tuple(5)           D) 5, 

U CO1 

13 What does range(7, 14, 2) generate? 
A) [7, 9, 11, 13]            B) [7, 9, 11, 13, 15]                         C) 
[7, 8, 9, 10, 11, 12, 13]      D) [7, 14] 

A CO1 

14 What is the output of 16 % 3?    
A)1 B)5 C)0 D)3 

E CO1 

15 What is the output of `5 + 3 * 2`?   
A)11 B)16       C)10        D)None 

E CO1 

16 Which of the following is a logical operator in Python?                    A) +
         B)or                     C)%                 D) & 

K CO1 

17 Which logical operator returns True if either condition is True? 
A) and     B) or  C) not  D)& 

A CO1 

18 Which of the following is a valid assignment operator in Python? 
A) +=        B) <  C) !=        D) > 

K CO1 

19 Which operator is used to compare equality in Python? 
A) '= =’       B)'=’ C) != D) <> 

K CO1 

20 What is the output of 5  > 3?   
A) TRUE B) FALSE     C) None D) Error 

E CO1 

21 What is the output of 15 & 7?   
A) 7 B) 8 C) 15   C) 0 

E CO1 

22 What is the primary operating system for Raspberry Pi?   
A)Windows B)macOS  
C) Raspberry Pi OS (formerly Raspbian)    D) Linux Mint 

U CO1 

23 Which Raspberry Pi model comes with an integrated keyboard? 
A) Raspberry Pi 400       B) Raspberry Pi Zero W                          C) 
Raspberry Pi 5            D) Raspberry Pi 3 Model B+ 

K CO1 

24 What type of HDMI ports does Raspberry Pi 4 have? 
A) Standard HDMI B) Mini HDMI   
C) Micro HDMI     D) DisplayPort 

U CO1 

25 What is the default username for Raspberry Pi OS? 
A) admin B) root        C) pi D) user 

K CO1 

26 Which processor is used in the original BeagleBoard? 
A)ARM Cortex-A8 B) Intel i5  
C) AMD Ryzen   D) ARM Cortex-M4 

K CO1 

27 What will be the output of the following code? 
x = 5 
if x > 3: 
   print('Yes') 
A)Yes         B) No   C) Error    D) None 

An CO2 

28 What will be the output of the following code? 
x = 7 
if x > 10: 
 print('Greater') 
elif x > 5: 

E CO2 



    print('Medium') 
else: 
   print('Smaller') 
A) Greater B) Medium C)Smaller D) Error 

29 What will be the output of the following code? 
for i in range(2, 5): 
    print(i) 
A) 2 3 4    B) 2 3 4 5 C) 3 4 5         D) None 

A CO2 

30 What will be the output of the following code? 
for i in range(3): 
    print(i) 
else: 
   print('Done') 
A) 0 1 2       B) 0 1 2 Done C) Done 0 1 2        D) Error 

An CO2 

31 What is the purpose of the while loop in Python? 
A) To define a function B) To iterate until a condition is met C) 
To handle exceptions D) To create a sequence 

U CO2 

32 What will be the output of the following code? 
x = 0 
while x < 3: 
    x += 1 
else: 
  print('Done') 
A) 0 1 2      B) 1 2 3 C) Done     D)  1 2 3 Done 

E CO2 

33 What will print("The number is {}".format(5)) output? 
A) The number is 5          B) The number is {5} 
C) Error               D) {The number is 5} 

A CO2 

34 How many GPIO pins are available on a Raspberry Pi 4 Model B? 
A) 26    B) 30    C) 40 D) 50 

U CO2 

35 What are the two numbering systems used in Raspberry Pi GPIO 
programming? 
A) Physical and Logical       B) Board and BCM              C) 
Digital and Analog                 D) Serial and Parallel 

K CO2 

36 Which Python library is commonly used for GPIO programming in 
Raspberry Pi?         
A) Rpi.GPIO B) PiGPIO  
C) GPIOControl D) PyGPIO 

K CO2 

37 Which function is used to read the state of a GPIO input pin? 
A) GPIO.input() B) GPIO.read()  
C) GPIO.state() D) GPIO.get() 

A CO2 

38 Which widget is used to display static text or images in Tkinter? 
A) Entry          B) Label       C) Button       D) Checkbutton 

U CO3 

39 Which geometry manager can be used to place a Label in a specific 
location? 
A) pack()       B) grid()        C) place()      D) All of the above 

K CO3 

40 Which option is used to specify a function to execute when a button is 
clicked? 
A) action         B) command        C) onclick            D) callback 

A CO3 
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1 
Which of the following is NOT a basic component of the Microsoft Word window? 
a) Ribbon, b) Taskbar, c) Status Bar, d) Title Bar 

K CO1 

2 
What is the shortcut key for creating a new document in MS Word? 
a)Ctrl + C, b) Ctrl + N, c) Ctrl + V, d) Ctrl + X 
 

K CO1 

3 
What happens when you press Ctrl + Z in a Word document? 
a) Redo the last action, b) Undo the last action, c) Copy the selected text,  
d) Paste the copied text 

A CO1 

4 
Which shortcut key is used to find a word in a document? 
a) Ctrl + F, b) Ctrl + H, c) Ctrl + P, d) Ctrl + S 

K CO1 

5 
What is the default file extension for a Microsoft Word document in newer versions? 
a) .txt, b) .pdf, c) .docx, d) .xls 

K CO1 

6 
Which of the following options is used to print a document? 
a) Ctrl + S, b) Ctrl + P, c) Ctrl + X, d) Ctrl + V 

A CO1 

7 
Which option is used to change the page orientation in MS Word? 
a) Page Layout → OrientaƟon, b) File → Print,  
c) Insert → Page Number, d) View → Zoom 

A CO1 

8 
What is the default page margin in Microsoft Word? 
a) 0.5 inches, b) 1 inch, c) 1.5 inches, d) 2 inches 

K CO1 

9 
Which key is used to create a manual page break? 
a) Ctrl + Enter, b) Shift + Enter, c) Alt + Enter, d) Ctrl + Shift + Enter 

A CO1 

10 
Where can you set Headers & Footers in MS Word? 
a) Insert → Header & Footer, b) View → Header & Footer,  

K CO1 



c) Format → Page Layout, d) File → OpƟons 

11 
How can you apply Bullets and Numbering to a list? 
a) Home → Font, b) Home → Paragraph,  
c) Insert → Symbols, d) View → Ruler 

A CO1 

12 
Which feature is used to change all instances of a word in a document? 
a) Find, b) Replace, c) Go To, d) Bookmark 

A CO1 

13 
What is the shortcut key for saving a document in a different format? 
a) F8, b) F9, c) F12, d) F7 

K CO1 

14 
Which tab in MS Word allows you to insert a table? 
a) Home, b) Insert, c) Layout, d) View 

K CO1 

15 
Which option is used to combine two or more cells in a table? 
a) Split Cells, b) Merge Cells, c) Insert Cells, d) Align Cells 

A CO1 

16 
What is the shortcut key to insert a new row in a table? 
a) Ctrl + R, b) Shift + Enter, c) Tab (when pressed in the last cell), d) Ctrl + T 

A CO1 

17 
In a table, which feature is used to arrange data in ascending or descending order? 
a) Merge, b) Sorting, c) Splitting, d) Aligning 

A CO1 

18 
Which tab allows users to insert ClipArt and Pictures in MS Word? 
a) Insert, b) Design, c) Layout, d) Home 

K CO1 

19 
What is a nested table? 
a) A table placed inside another table, b) A table with different border styles,  
c) A table with multiple merged cells, d) A table created using formulas 

K CO1 

20 
Which feature in MS Word is used to perform Mail Merging? 
a) Review, b) Insert, c) Mailings, d) View 

A CO1 

21 
What is the purpose of the Thesaurus in MS Word? 
a) To check grammar, b) To find synonyms and antonyms,  
c) To check spelling, d) To insert hyperlinks 

K CO1 

22 
Which of the following allows you to automate repetitive tasks in MS Word? 
a) Spelling and Grammar, b) Macros, c) Word Art, d) AutoShapes 

A CO1 

23 
What is a spreadsheet primarily used for? 
a) Writing documents, b) Managing data in tables,  
c) Editing images, d) Designing graphics 

K CO2 

24 
Which option is used to open a spreadsheet in MS Excel? 
a) File → New, b) File → Open, c) Insert → Worksheet, d) View → Excel 

K CO2 

25 
The Formatting Toolbar in MS Excel is used for which of the following? 
a) Inserting charts, b) Applying text styles and cell formatting,  
c) Sorting data, d) Protecting the worksheet 

A CO2 

26 
Which of the following is used to select a range of cells in a spreadsheet? 
a) Clicking one cell only, b) Dragging across multiple cells,  
c) Pressing Ctrl + A, d) Pressing Shift + Enter 

A CO2 

27 
How can you move the contents of a cell to another location in Excel? 
a) Copy and Paste, b) Drag and Drop,  
c) Use the Delete key, d) Use the Clear All option 

A CO2 

28 What happens when you cut a cell in Excel? A CO2 



a) The cell content is removed and copied to the clipboard,  
b) The cell content is permanently deleted,  
c) The cell is duplicated in the new location,  
d) The cell content remains in the original position 

29 
Which option allows you to insert or delete cells in Excel? 
a) Right-click → Insert, b) Home → Merge, c) View → Freeze, d) File → OpƟons 

A CO2 

30 

What is the function of Freezing Cells in Excel? 
a) To protect cells from being edited,  
b) To keep selected rows or columns visible while scrolling,  
c) To delete a cell's content,  
d) To move cells across different worksheets 

A CO2 

31 
How can you paste copied cells in Excel? 
a) Right-click → Paste, b) Click the Paste buƩon on the toolbar,  
c) Press Ctrl + V, d) All of the above 

A CO2 

32 
Which option is used to add a new worksheet in Excel? 
a) Home → New, b) Right-click on a sheet tab → Insert,  
c) File → New, d) View → New Worksheet 

K CO2 

33 

How can you rename a worksheet in Excel? 
a) Double-click the worksheet tab and type a new name,  
b) Right-click on the worksheet tab → Rename,  
c) Go to Home → Format → Rename, d) Both a and b 

A CO2 

34 
To align text within a cell, which option should you use? 
a) Home → Font, b) Home → Alignment,  
c) View → Text DirecƟon, d) Insert → Alignment 

A CO2 

35 
Which feature is used to wrap text within a cell? 
a) Merge & Center, b) Text Wrap,  
c) Format Cells → Alignment → Wrap Text, d) AutoFit 

A CO2 

36 
How can you apply borders to cells in Excel? 
a) Home → Format → Borders, b) Home → Font → Borders,  
c) Right-click → Format Cells → Border, d) Both a and c 

A CO2 

37 
Which function in Excel is used to arrange data in ascending or descending order? 
a) Filter, b) Sort, c) Rank, d) Format 

A CO2 

38 
Which option is used to center a heading across multiple columns in Excel? 
a) Merge & Center, b) Align Center, c) Wrap Text, d) Center Align 

A CO2 

39 
How can you change the row height in Excel? 
a) Right-click on the row number → Row Height, b) Home → Format → Row Height,  
c) Click and drag the row boundary, d) All of the above 

A CO2 

40 
What feature automatically adjusts cell formatting based on the data type in Excel? 
a) Conditional Formatting, b) AutoFormat, c) Format Cells, d) Cell Styles 

A CO2 
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